Back

Snowflake Service Outage in EU Central (eu-central-1)

September 4, 2026 at 07:52 AM UTC Resolved after 2h 2m

Updates

Resolved

Region: eu-central-1
The incident has been resolved. The complete data refresh is going to be fully restored in a few hours.
An RCA will be completed for this issue. If you are still experiencing any issues or would like a copy of the RCA, please file a case with Docebo Support.

September 4, 2026 at 09:55 AM UTC
Monitoring

Region: eu-central-1
Snowflake has determined the root cause and mitigation efforts are underway. The mitigation has been applied.
We will continue to monitor the situation to ensure recovery.

September 4, 2026 at 09:22 AM UTC
Identified

Region: eu-central-1
We are continuing to monitor the third-party Snowflake Service Outage in EU Central impacting customers. We'll provide another update within 30 minutes.

September 4, 2026 at 08:52 AM UTC
Identified

Region: eu-central-1
We are continuing to monitor the third-party Snowflake Service Outage in EU Central impacting customers. We'll provide another update within 30 minutes.

September 4, 2026 at 08:22 AM UTC
Identified

Region: eu-central-1
Our upstream provider, Snowflake, is currently experiencing an issue which is affecting our ability to generate reports, insight dashboards and Learn data connections. See https://status.snowflake.com/ for more details.
We will resolve this incident once we have received confirmation the issue has been resolved from our upstream provider.

September 4, 2026 at 07:52 AM UTC